Major outage
Incident Report for KitsuneHosting
Resolved
Fidum is back.
Posted Oct 02, 2023 - 16:29 EDT
Investigating
Major networking outage, will update as information comes in
Posted Oct 02, 2023 - 14:27 EDT
This incident affected: Media (Plex), Gameservers (1721 Server, STI Modded Server), and Storage and Backup (Nextcloud).